Jump to content
Official BF Editor Forums

Daniel S

Members
  • Posts

    31
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Daniel S's Achievements

Apprentice

Apprentice (3/14)

  • First Post Rare
  • Collaborator Rare
  • Dedicated Rare
  • Conversation Starter Rare
  • Week One Done Rare

Recent Badges

0

Reputation

  1. I took your original advice and brought them into 3DS Max, converted them to static, created hierarchies and exported. I now have all the vehicles as Static Objects! It's great! Anyone who wants a complete tutorial on the process, I will be happy to provide. Or I can share the finished staticobjects (if that's allowed). If I haven't stated it previously, I am doing this only for my own use and enjoyment.
  2. I'm sorry no one has answered. I have the same question, I suppose no one know? Is that possible?
  3. I have max installed. I have the tools installed. I import a vehicle (usjep_hmmwv) that I want to work on. It imports, but what is imported is the "wrecked" state. I know the mesh file includes the main model and a wrecked version of the model (different lods or geoms: geom1 geom2...I think...forgive me if I use terms wrong...) My question is, in Max, how do you switch to the other geom or other state? Thanks for any help.
  4. I have it almost figured out. I just need a little help getting over the finish line. I have successfully created a Static Object from a vehicle. I figured out the "missing tires" issue. I figured out the issue where the object would move if shot at (I gave it a heavy weight and now it doesn't move). As you can see in the picture, I made the xpak2_semi into a static object. The only challenge left is to figure out why it looks sunk into the ground. Adjusting the height number in the editor makes no difference. Adjusting the height number in "StaticObjects.con" makes no difference. I tried to find something in the Con file (in objects_server) but I could find many parts that I could change the height of (steering wheel, tires) but I could not find the name of the main body of the truck. How do I find out the names of all the parts of the object? For example, the steering wheel is named "SteeringWheel" and the left front tire is named "LFwheel" and so on. I can change these parts' position and the change shows in the game (example in 2nd pic). So I feel like the answer is finding the "name" of the main truck body and using that in the con file to set its position. Any help is more than greatly appreciated....
  5. Progress? I fiddled around with the syntax, switching out between "PlayerControlObject" and "SimpleObject" and "RotationalBundle" and "Bundle" and I got to the point where the "jep_vodnik" shows up correctly....with its tires. BUT...unfortunately, when I launch the game, it's just not there. (see pic) SO....what would cause an object to be visible in the editor but not the game itself?
  6. Here's what I want to do. I want to transform some vehicles into static objects. I want them strewn about the map, looking like they are junked or on fire or whatever. I know that there are a couple of wrecks already, but I want to create specific vehicle static objects. I have already copied the desired vehicle folders from the "vehicle" directory to the "staticobjects" directory in the objects_server and objects_client of the BF2 mod folder. I have edited the con file and changed "ObjectTemplate.create PlayerControlObject" to "ObjectTemplate.create SimpleObject" and removed any references to sounds or movement. I have had minimal success. The problem is, for example, when I create a static object of the "jep_vodnik" I get the basic vehicle, but it has no tires. When I create a static object of the xpak_semi, it is there and even has the tires, but they are above the vehicle instead of where they should be. I appreciate any help with understanding what to do to make this work. Please no posts saying "why would you want to do this" or anything similar. I want to do this and if you can help, I would appreciate it. -Daniel
  7. Figured it out.... Went to Compile>Lightmaps>Generate Lightmaps and that fixed it....
  8. Using BF2editor and playing around with a map I created. I changed some terrain by raising it. There are these places that used to be trenches that I raised up to be level with the higher ground....and these places that used to be low, are now darker and no amount of painting textures does anything. There are also places where objects used to sit, that I deleted, and now those spots are darker too. Photo attached. The dark area used to be a trench that I leveled-up but I can't make it lighter for some reason.... Any suggestions?
  9. We're still reading these forums and putting the info to good use. I hope someone will see this: I am trying to use the method described here to draw splines and make the terrain deform to the slope of the splines. I have used BF2editor quite a bit and feel like I am not a Noob and not an idiot. But I can't get the terrain to conform to the road splines as described. I followed the steps exactly: Create splines, connect, apply. I am experiencing the thing others describe (the terrain disappears when applying). I tried saving, closing the editor and then coming back in and I noticed that the terrain is changed, but not as expected. Instead of bringing the terrain UP to the spline, a big chunk of the terrain is REMOVED instead. Any help is appreciated....
  10. Does anyone have the "LPP_BF_Collection_Setup.exe". The download link is long expired and I would love to have this tool. BTW: I love how the first person asks the question....and then one guy gives a lecture about searching instead of asking....then a bunch of other, nicer people set about to answer the question. That's how it should be. Help if you can....otherwise, keep scrolling.
  11. Now gone too. Can anyone re-up the PDF file of Kysterama's tutorial? Thanks!
  12. Sorry if this has been posted....but I am having no luck finding the "fixnavmesh.bat" file that is mentioned so many times throughout this thread. Any help is greatly appreciated! -Daniel
  13. When I run fixnavmesh.bat it states "Level not found!" Any help appreciated! -Daniel
  14. I must be missing something. There is reference to a file called "fixNavmesh.bat" but I can't find any indication of where to get this file. Sorry if I'm dumb.... -Daniel
×
×
  • Create New...