Jump to content
Official BF Editor Forums
Sign in to follow this  
Dumptrailer2

Createnavmesh.bat Does Nothing

Recommended Posts

Hello, you probably haven't seen me in a while, but I'll get to one of my problems that just arose while trying to create a navmesh.

When I click on "createnavmesh.bat" it does nothing after I type in my mod name and the level name. It just says "Usage:(something about savequadlocalp4)". I tried setting all the compatibility settings and "run as administrator" for all the navmesh things, but I still get the same message. I have also noticed that I recieve the same above message when I click on savequadlocalp4 (or one of the python files, can't remember what it is). It doesn't open up the editor or start generating the mesh or anything.

Can anyone shed some light on this problem?

I have generated navmesh before, so I don't know why this is happening, it might possibly because I now have vista. Has anyone else with vista had luck generating a navmesh?

Thanks,

Dump2

Share this post


Link to post
Share on other sites

First make sure that you have Python installed again. Check at the Python site if they run it successfully under Vista and make sure that *.py files are associated with Python. (Doubleclicking a *.py file should launch the Python interpreter, not a texteditor )

Next check if you have copied the two *.con files from the /Navmesh folder into the <BF2.EXE> folder , that is one level below the/navmesh folder.

Share this post


Link to post
Share on other sites

I have checked and python is compatible with vista, and the files are opening with python. I also do have the two files in the bf2.exe folder.

Share this post


Link to post
Share on other sites

Hmm, i suppose the map you want to navmesh does exist ? Maybe the batch file issues an error ? Enter a line with 'pause' in it at the end of the batch file to get the chance to look at any errors.

If you're still unsuccessful maybe check with the guys at BFSP if they have run navmeshes with Vista. I'm no help with this cause i run XP here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×