Jump to content
Official BF Editor Forums
Sign in to follow this  
FVxSF

Need Help In Replacing Sounds

Recommended Posts

Last night I was thinking about the weapon sounds of 2142. There are some sounds I'd like to replace, like the shot gun, VOSS and SMGs to name a few. But when I went to replace the VOSS sounds I get an odd problem. Fist was that the sound was playing waaay to fast in that it sounded like really bad static. I was able to fix that because the bit rate of the WAV file was like 320-ish not 1411. Now here is the problem I can't figure out. If I set the VOSS to single fire the new sound works great however if I switch to full auto I don't hear it like a machine/full-auto gun. I plays the sound once and waits to loop then plays again. If this doesn't make since, I'll see if I can get a quick video to so you.

In the mean time, does any one have info on the BF sound engine? Such as what type of WAV format is used, bitrates etc.

Share this post


Link to post
Share on other sites

Hey, not sure about your problems with auto fire sound, not my area..but sure others will help soon.

Here is a usefull thread though that has all the other info in.. download the bf2 sounds tools and its a simple drag and drop over the exe to convert a wav to ogg for bf2... http://bfeditor.org/forums/index.php?showtopic=9893

Share this post


Link to post
Share on other sites

I'm using the Trial Version of Adobe Audition and once school starts I can use their full version. But the OGG files are for the menu and map load music. The WAV files are for all the sound effects.

I was going to make a quick video last night but decided to take a 5 hour nap instead. I'll see if I can't get the video tonight.

Share this post


Link to post
Share on other sites

Ok, So I got a quick video to show you the problem. You'll need M$ Silverlight (which isn't too bad if you ask me.. WMV has really good video quality too) Or you can download the video.

Video -> http://fvxsf.com/archive/2142/videos/

===============================================================

Ahhh there we go! The marker.. I forgot to click the "Save extra non-audio Information" checkbox.... Well now that I have that sorted out. If any one else is having the same issue, make sure you see a Cue Marker in your WAV file. Then save it as a Windows PCM WAV Format. That should do the trick.

Now... off the the blood thread...

Edited by FVxSF

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...