Jump to content
Official BF Editor Forums
Rhino

Could Not Find Valid Technique For The Shader

Recommended Posts

Hey guys, searched high and low for this problem I've been having about the forums but the very few things like it that I have found are really old topics, not quite the same problem and have been unsolved so hoping you guys might be able to help me.

Ever since my system upgrade a few months ago, the main part of it being my new nVidia GTX 260 from my ATI x1950pro I've been having this really odd bug with the editor after lightmapping.

The basic problem is that I can load any map fine, and I can lightmap objects and terrain 100% fine too, but after the lightmapping task is done, ie, a few crates I've selected or w/e, before my upgrade etc the editor use to restore back to the level fine, showing all the updated lightmaps etc. Now how ever, what happens is after the lightmapping is done, my view simply dose not work, it dose not update and the only thing it shows is my selection arrow bit and if I try and move my screen around, all I get is loads of these arrows about etc.

Just as a quick example, I just lightmapped this crate on the left so I could turn my overgrowth into static, now as you see in this screen I have 3 things with a move bit on them, where normally you can only have one, that is because in fact I only have one thing with the move arrow bit on it, its just the fact that when I unselected the crate and the other bit, it did not update...

82377687dx0.jpg

so ye, the overgrowth is there as I've selected it, but the view has not updated to show it or the changed LM on the crate on the left etc.

Now if I move my view over to the left, this is what happens.

10554241lg4.jpg

notice the terrain etc has not moved, but now I've got loads of selection arrows all over my screen...

You can also notice in the screenshots at the bottom the repeated error which I'm pretty sure what this problem is related to:

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

Ignored Warning[Ra] : Could not find valid technique for the shader: shaders/rashaderstmbasedetailndetaillightmap.fx

so ye, as you can see this is quite annoying as now I have to restart my editor in any way to view my lightmaps or w/e I want to do after lightmapping a object...

I'm pretty sure this is in some way related to my new gfx card, but I dont know how to fix it, tried reinstalling the editor, new drivers for my GFX card etc, tried getting that shader of a mate then replacing it with the old one, but nothing seems to work... Any one got any ideas?

Cheers! :D

Share this post


Link to post
Share on other sites

To me it looks as if you pinpointed the problem already , its your new graphics card :unsure: But i have a few questions :

What happens if you change render mode , do you get a refresh then ?

What render mode are we seeing in the screenshots ?

Does the NVidia Control pannel accidently switch away from application settings to a preset ?

Did you try to reload lightmap or other textures in the editor with the command editor ? E.g. entering the command 'texturemanager.reloadTextures tx0' would reload all detail-, color- and terrainlightmaps on the fly.

Share this post


Link to post
Share on other sites

cheers, also did a little more testing last night and when I render only terrain lightmaps, its fine, reloads and restores the view as normal, its only when I render light maps for objects... dont matter what object or what objects are in the map...

have not tried switching render mode, but w/e render mode I've started in has the same effect, may try switching render type after but dunno if it will help.

that render type in the SS is overgrowth mode render, just showing where I've painted my overgrowth.

not sure what you mean by the nVidia CP bit, care to explain a little more?

and no, aint tried reloading it by hand but my editor has no probs reloading changed terrain, objects and terrain lightmaps, just after rendering a object's lightmaps it screws up...

cheers for the help.

Share this post


Link to post
Share on other sites

Nvidia installs a control panel where you can adjust graphics settings depending on a application. These settings will be applied once the control panel detects that this application is launched. By default the control panel lets the application decide what settings to use but if the program is found in the application specific settings the control panel will force the graphics card to use the control panel settings.

Check if adding the 'bf2editor.exe' to this helps and give it 'vertical sync ON' setting. To me it looks as if this could help. I think by default the editor sets this to 'ON' anyway ( i never got higher frames in level or terrain editor than 30 Frames per second which points to this ) and it might possibly help with refreshing the screen.

Share this post


Link to post
Share on other sites

Ok, but running the (32-bit) editor on a 64-bit system is quite a different issue. In any case you need to set compatibility settings for the editor to give it a 32-bit environment.

Afaik Rhino runs on XP and his problem seems to be GC-driver related.

Share this post


Link to post
Share on other sites
' date='01 September 2009 - 05:26 PM' timestamp='1251840383' post='90782']

Ok, but running the (32-bit) editor on a 64-bit system is quite a different issue. In any case you need to set compatibility settings for the editor to give it a 32-bit environment.

Afaik Rhino runs on XP and his problem seems to be GC-driver related.

Anyone find any kind of solution to this yet? I don't mind even rolling back my drivers to the dawn of time if I have to.

Edited by Lainer

Share this post


Link to post
Share on other sites

Anyone find any kind of solution to this yet? I don't mind even rolling back my drivers to the dawn of time if I have to.

Nope, just restart after LMing or LM with 3DsMax.

Share this post


Link to post
Share on other sites

having the same issue with my GTX1660.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×