Jump to content
Official BF Editor Forums
Called

Wierd: Eu Taitan Starts With Shieeld Down/no Air Vehicles

Recommended Posts

Hi all. I'm remaking Songhua Stalemate for BF2142 and am including a Titan mode. It's really wierd, but the EU titan starts with shields down and no air vehicles. I didn't do anything to the code or the Titan object. Here's how I loaded the Titans:

rem ********** Object Spawner **********

rem [ObjectSpawnerTemplate: Fish Processing_Titan]

ObjectTemplate.create ObjectSpawner Fish Processing_Titan

ObjectTemplate.activeSafe ObjectSpawner Fish Processing_Titan

ObjectTemplate.modifiedByUser "martin"

ObjectTemplate.isNotSaveable 1

ObjectTemplate.hasMobilePhysics 0

ObjectTemplate.setObjectTemplate 2 eu_titan_playtest

ObjectTemplate.maxSpawnDelay 30

ObjectTemplate.Distance 1000

ObjectTemplate.teamOnVehicle 1

ObjectTemplate.nrOfObjectToSpawn 1

rem [ObjectSpawnerTemplate: Village_Titan]

ObjectTemplate.create ObjectSpawner Village_Titan

ObjectTemplate.activeSafe ObjectSpawner Village_Titan

ObjectTemplate.modifiedByUser "martin"

ObjectTemplate.isNotSaveable 1

ObjectTemplate.hasMobilePhysics 0

ObjectTemplate.setObjectTemplate 1 as_titan_playtest

ObjectTemplate.maxSpawnDelay 30

ObjectTemplate.Distance 1000

ObjectTemplate.teamOnVehicle 1

ObjectTemplate.nrOfObjectToSpawn 1

This code is from Suez Canal originally. I pulled the GameObject.con from Suez Titan into the editor and re-arranged it for my map -- just changing the CP names and some of the spawns after placing them where I want them in my map. Why would only the EU Titan start with shields down and no Air spawns? I couldn't have created that combo if I tried! lol.

Any help is appreciated.

Called

development Team Leader

TournAMENT gAMING wORLD

2142 tOURNAMENT

Share this post


Link to post
Share on other sites

It says test maybe its a test object titan? Are you sure u copied it from the correct game mode?

Share this post


Link to post
Share on other sites

To continue the sad story --- I was loading a custom object "supply_object" that was conflicting with the Titan. Deleted that and all fixed. Thank God!

Edited by Called

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×