Jump to content
Official BF Editor Forums

Flickering Black Textures, Help !


Michael_Quay
 Share

Recommended Posts

First of all, sorry for my bad english

Yesterday, I ran BF2 with Max settings perfectly. But I so bored about game graphic when far and i try to turn on AF 16x by CCC and WTF ???

untitled-2.jpg

Then I turn off AF in CCC and it still there

untitled1-2.jpg

I do anything (update driver, Reinstall game,...)and still have it

T was try this: http://www.bfeditor.org/forums/index.php?showtopic=9061 =>Cant

I can fix it by set terrain to Low but it's look too suck

My PC:

OS: Window XP Sp3

Intel core 2 duo e4500 (==!)

Ram: 2,5Gb

VGA: Ati Radeon HD 4560

Fixed: Downgrade driver

Edited by Michael_Quay
Link to comment
Share on other sites

Yes and that is because ATI cards use different shaders for dynamic shadows. I have looked into the shaders and it seems like in some development state all the shadows were dynamic even point lights casted dynamic shadows. In the release version most shadows are done with lightmaps but there are still some dynamic ones. And the flickering black area is technically a shadow.

Link to comment
Share on other sites

Yeah and problem is: before I can run it perfectly and after i force AF 16X =>Problem happen. I try to do anything clear old driver and update, Disable CCC, .... anything I can find in google. Any ideas for help, plsss

P/s: Yay, I fixed it, just downgrade my Card driver, thanks everybody for watch my topic

Edited by Michael_Quay
Link to comment
Share on other sites

isnt it a known ATI problem?

think i can remember misch told me in the past that he had the same problems all the time and it seems to be a known problem with ATI gfx-cards.

No, and thats why i didn't say anything. It was a known NVidia (!) problem :blink: and it happened mostly with the debugger. Glad to hear that ATI managed to copy that bug :angry:
Link to comment
Share on other sites

I'm betting the reason it happens with the debugger is because the .exe isn't named BF2.exe. If I change the name of my BF2.exe and run the game I get this bug (geforce 9800GTX+).

Thats interesting. I noticed I was getting this same error when using Kev4000's 1.5 Debugger, But not in vbf2, or 1.41 Debug. It may be important to note that Kev changed the name of the exe to aBf2_r.

Edited by Coronaextra
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...