Jump to content
Official BF Editor Forums

Water Color Not Corrosponding


bladecx321
 Share

Recommended Posts

I'm sorry, I couldn't find ANYTHING about how to make my water transparent... Nothing that worked anyway. I tried this:

"To get your water transparent you generate lightmaps. If its for testing just do medium lightmaps. If you have already done them it could have been an error while generating them. So go into your levels/yourmap/lightmaps folder delete all the lightmaps in there (there will bee a load of .dds files) then go to levels/yourmap/lightmaps/objects and delete all the .dds files in there also. To be sure open the LightmapAtlas.tai file with notepad and delete all the references to your objects in there. (there will be a long list). Then pop back into editor and generate lightmaps Terrain (and objects if you want) in medium.

What this does its makes your land mass go darker the deeper the water is. So close to the shore you get nice transparent water and as it goes deeper you just get the water colour.

Envmaps give you reflections only not transpanrency. You do this when you have finished your map ;) "

That did not work for me... I changed my values for WaterFogRange..would that have something to do with it?? I have a few ponds in my map and they're just solid blue right now... No waves, no transparency, nothing. Please help!

Link to comment
Share on other sites

My water is pea green... My water color is set to blue. When I look at my water in the editor, it's the blue that I have selected. When I look at my water in game, the shadowed areas (shadowed by trees/rocks/buildings/etc) are the blue that I have selected, but the other areas are this nasty pea green. I can't find anywhere that I have ANY colors set to this nasty green. Any ideas on why this is, and how to fix it?!

***EDIT***

Well, I changed WaterFogColor to white as well as WaterSpecularColor... They were shades of blue. It changed the green to black. For some reason my TerrainWaterColor is stuck on black... I changed it to white and then saved, regenerated EnvMaps, but my water is still blackish... (see it here) And I want my water to look like THIS.. :(

Edited by bladecx321
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...