Jump to content
Official BF Editor Forums
Sign in to follow this  
Terminal-Access

Level Strange Water Reflection Problem

Recommended Posts

Hey guys i am wondering if any one has come across this before, in any level i create using the BF2Edtitor setup for BF2142 i seem to have a very strange problem with what i think is the reflections on my waterlevels

the problem is that half of the water on my map seems to have no reflection what so ever and look like it has a mat finish as a pose to the nice glossy reflection finish of the othr half

i have linked to two pics that show the problem better than what i am describing.

Normal shot of my level/

460Water_shading_or_refle.png

Shot of my level With the water level set above the terrain.

954Water_shading_or_refle.png

I have followed [EoD]Junglist Tutorial Creating A Map For Begginers - (very Image Heavy) to creative this level

Its a tesating map thuis not a lot of content.

i have completed al steps mentioned in the tutorial including

Fully light mapping the level and implamenting the proper evnmap's and hemimap

i just have no idea whats going on.

i am wondering if its some thing to do with how the mod is set up, or how my editor is set up or even if its to do with my graphics card

and Just incase my Grfx card is an XFX Radion HD 6870 Black Edition with the very latest drivers (one of the first things i checked when i noticed this was if i was running current drivers.)

any help would be greatly apreciated.

thanx

Lee

Edited by Terminal-Access

Share this post


Link to post
Share on other sites

Looks like the same issue that this guy had.

http://www.bfeditor....showtopic=15622

I still think its a lightmap issue. Look at your lightmaps in a DDs viewer. Shallow water should be blue, deep water should be pink. If its different than you know theres a problem.

Also, you can try this. Edit the terrain somewhere that doesnt matter and adjust the water level slightly, then save terrain and compiled terrian. Restart the editor and re-lightmap the level.

Edited by Coronaextra

Share this post


Link to post
Share on other sites

Looks like the same issue that this guy had.

http://www.bfeditor....showtopic=15622

I still think its a lightmap issue. Look at your lightmaps in a DDs viewer. Shallow water should be blue, deep water should be pink. If its different than you know theres a problem.

Also, you can try this. Edit the terrain somewhere that doesnt matter and adjust the water level slightly, then save terrain and compiled terrian. Restart the editor and re-lightmap the level.

thanx for the reply and yes i agree its a lightmapping problem, however a bit of good news, it appears this is only an Editor bug for me as when i run the acctual level the water is fine.

its more than likely some thing to do with the way my editor is set up, so for now its not that important afterall.

thank you for the reply though !!

Share this post


Link to post
Share on other sites

More exact, its an ati card editor bug, as said by CB will be ok ingame, only problem is doing the minimap image.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×