Jump to content
Official BF Editor Forums
Sign in to follow this  
marcofratini23

Ctd When Loading Poe2

Recommended Posts

I was merging my battlefield 2 contents, so I can play like and all in One, I merged the Vanilla battlefield 2 content in special forces without any problem. levels open perfect and now I can use the SP contect with the regular vanilla armies.

I try also merging POE2 to this. I added the content via ClientArchives.con and ServerArchives.con way, I copy the levels and Start loading for a trial, When the bar reach the Textures part is when I get the CTD. any ideas of what is happening? I read in other forum and they said that some mods are not possible in merging or that is maybe a doble textures in client archives that battlefield 2 doble load and Crash...

Share this post


Link to post
Share on other sites

Merging Mods can be tricky since they often share geometry/texture/template names. There is probably no easy way to do this but I would start by figuring out what is shared and either ommit it or change names or loading paths until the confilcts are resolved.

If you run the game in debug or windowed mode it will produce and error message when it crashes that will tell you what the problem is (in most cases)

Windowed mode is easy, just create a shortcut on your desktop with these parameters

+menu 1 +restart 1 +fullscreen 0

Debug Mode

Also, make sure you merge Common and Menu archives. These contain Hud, Terrain, Sky textures, sounds and alot more that it will need to load.

Good Luck!

Edited by Coronaextra

Share this post


Link to post
Share on other sites

Thank you!

I was able to merge BF2 with Poe2 without any problem... but every time I try to add poe2 when battlefield 2 is with the Special Forces, It tells me that doesn't find a texture... that is actually in the client archives... I don't know what else to do. Maybe merge Special forces with Poe2... I don't really know...

Share this post


Link to post
Share on other sites

What error message does debug/windowed mode provide you? Which texture is missing?

Also, how did you merge the mods? Did you merge all the zips into one giant one or did you build a file mount in server/client archives?

Share this post


Link to post
Share on other sites

Your CTD is caused because,even though your mod has all the needed files

You are missing 1 important step required when combining mods that have their own atlas

just like your archives load the files and in the order you want

you must also update your AtlasList.con file,because as it is,your mod is only loading the atlases,which are listed in your first loaded AtlasList.con file,because the game will only load the first instance of any file*

whichever mods atlas is listed first in the AtlasList.con file,will override any same named textures/files in the lower listed atlases

Note HudSetupVehicles.con & HudSetupWeapons.con should also be updated if you want all working HUDS,(but wont CTD if you dont update them)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×