Jump to content
Official BF Editor Forums

MAP CRASHES WHEN LOADING UP IN GAME


bullstone
 Share

Recommended Posts

Finished making a map and everytime i try to load it up in the game it starts loading get to about 15% objects then the whole game shuts down and returns to windows with no error reports...... any ideas

I had set my level settings like u should however im not sure if the physics have been enabled though

please help

I have made a couple of other maps that arent finished and they seem to do it too but they let u play for a few minutes before it shuts down and returns to windows......... I dont know whats going on this map was map the exact same way as the others

Link to comment
Share on other sites

Finished making a map and everytime i try to load it up in the game it starts loading get to about 15% objects then the whole game shuts down and returns to windows with no error reports...... any ideas

Im getting exactly the same thing! ive read that putting your graphics settings to medium sorts the problem or edtiing your bf2 shortcut and puttting fullscreen to 0 instead of 1 to help with errors but it does'nt work for me!

Im not being rude but seeing as i was told this is the official bf2 editing site i would have thought there would be a lot more help on this!

I can see my map name and add it but i do not see my map in the map screen (should i see it as its my first map??) and the game loads up to around 15% etc etc then crasshes to desktop.

Please remeber us new mappers find it harder than you brainy advanced mappers!

Link to comment
Share on other sites

ok i solved half my problem,when i followed the tutorial creating a basic level i only put in two control points and two spawn points (one for each team).I loaded up my map and was surprized to find that it loaded all the way!

Unfortunatly like the above post it crashed to the desktop as soon as i clicked join game,so now im a bit further but still back to square one!

Link to comment
Share on other sites

I think i may have solved this problem (hopefully)

this is how i got my map working,follow making a basic terrain and a basic level tutorial BUT only put in ONE control point for say china and one spawn point and ONE control point for say usa and one spawn point.

Now select the usa flag and in the tweaker bar you should see

controlpoint

absolute posistion

layer

team

and a lot of other bits but its the TEAM bit you want to click on.Now click on the number next to it and set it to 2,now deselect that flag and go to your other flag.

Select your china flag and your see the same bits come up in the tweaker bar go to team and change the number to 1,deselect the flag.

Now go to level settings and china should be team 1 and usa should be team 2

Save all and then load your map.

Go to options and change terrain to MEDIUM and all your other settings can stay on low or off.Add your map and with a bit of luck your map should load!

Please let me know if this works for you !

Link to comment
Share on other sites

The map crashes at 15% due to the overgrowth not being done correctly. Simply delete the overgrowth folder and any overgrowth files from your maps directory. The map genera;;y crashes when you click Join Game because of the graphics settings. As was mentioned some time ago, there was an issue with running custom maps with the video settings set to low. Simply make all settings on the video options set to medium and away you should be able to go.

Link to comment
Share on other sites

Hi Guys,

Had the same problems both the 15% load and the crash to desktop.

I renamed the overgrowth folder (renamed_overgrowth) {just incase this did nothing to help the problem} and also set my video setting to Medium.

The map loaded and worked fine. :P

For ref I'm running modest spec:

AMP Athlon 2100+ running at 1.74 Ghz

Gigabyte K7 Triton GA-7DXE Motherboard.

1 Gig Ram (PC2100)

BFG 6600 GT OC

For additional ref: I had also followed the Terragen landscape import/height map tutorial and at first thought this may have something to do with the crash. Glad to confirm it hadn't...

Hope this helps.. and thanks to [LoF]Phoenix

Cheers PP

Link to comment
Share on other sites

Got mine to work !

Had the same problem with crashing at 15% loading.

Had the same exact debug assertion failed error.

this is what i did to get mine to work.

1. Opened the editor and just laid some basic overgrowth down. not much just a small area. then saved it all. (i didnt delete the overgrowth file cause it didnt seem right to me).

2. Then used the mod manager and packaged the map only.

3. Transfered the 3 files to the BF2 mods folder.

server.zip

client.zip

info folder

Then ran the map first in windowed format. no adjustments to the video settings. Ran fine. Then ran in full screen mode = ran just fine. No crashes at all.

I think its all about the overgrowth not being set yet. as has already been mentioned. But... it still wouldn't work untill i packaged the map.

Try that. It worked for me.

Link to comment
Share on other sites

I had a problem when the game would crash @ 14% when i was loading a custum map. What i did was uninstall the editor and battlefield 2 (don't delete your profile) and it worked! I hope this will help anyone with this problem.

P.S. When you save in the editor leave all the boxes at their default. Do NOT check any other boxes!

Link to comment
Share on other sites

Me too..... i have posted a couple of times now trying to get to the bottom of this..... My map is all finished and loaded to our server.... but i just cant get onto it.... ie crashes at 15% - now i dont have any overgrowth on my map..... would it be an idea to just put some in.... ?

sorry im just a little confused on this matter.... i cant see the wood for the trees so to say....

Link to comment
Share on other sites

Now go to level settings and china should be team 1 and usa should be team 2

Save all and then load your map.

Go to options and change terrain to MEDIUM and all your other settings can stay on low or off.Add your map and with a bit of luck your map should load!

Please let me know if this works for you !

I'm having the same problem, it IS NOT the 15% thing.

WHen you say "go to options and change terrain to MEDIUM", is that in bf2, or the editor? I cannot find that option in the editor.

Edit: You meant in BF2, and YOU WERE FUCKING CORRECT! I was about to give up this whole thing, thanks for the tip.

Will this affect other players if their terrain is not set to medium?

Link to comment
Share on other sites

It should'nt effect other players if their settings are different (unless they have their terrain set lower than medium,maybe)and yes i did mean set terrain to medium in the game not the editor.

There was another member who said to delete the undergroth files but i did'nt have to do that at all (plus i did'nt see the point as i had no undergroth anyway!)

Still the bf2 editor is a bit like the moh radient it can be a bit fussy at times at what it wants to do (well my copy seems to be lol)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...