Jump to content
Official BF Editor Forums

FAQ : Map crashing at 61% - couldn't find LightMapAtlas.tai


Recommended Posts

Ok, i've been reading the forums for endless hours over the past week and have fixed every error i've had so far, and have learned a lot,



crashes loading the map at 61%, saying could not find lightmap/objects/lightmapatlas.tai

Yes, i 'have' searched before i posted, as i did for all my previous errors, but for this error, most of the time, the problem goes unanswered.

In one of the threads with an answer, I discovered that it occurs by using

Compile > Lightmaps > generate atlas light maps

And that you shouldn't really be using this anyway, that you should only be using generate light maps.

Ok, yes, i know i shouldn't have done it, heh, i read that "after" doing it.

The solution given so far was to delete everything out of the lightmaps folder, and then re-generate lightmaps the proper way.

That didn't work, it still asks for the tai file when loading.

So my question is, is there a way to fix it, or get it to NOT ask for this file,

or at the very least, if no solution is around, is there a way for me to somehow load up a new map with the work i've done so far on this map? Like copying the terraindata.raw or some other file or something.

Summary, asking for lightmapatlas.tai, HAVE deleted lightmaps and regenerated lightmaps - still asking for it.



Link to comment
Share on other sites

make another map the same size as the one you you are working on now call it "test" ...

then when it opens in the editor close the editor

and use the brand new lightmap folder from your test map and erase the lightmap folder in your messed up map and replace it with the new lightmap folder from your test map... GL CB

Link to comment
Share on other sites

  • 9 months later...

I'm having a similar problem - well thought I was. My map is crashing at 61 or 62% It very briefly flicks to 62% then reverts to 61% before CTD. I tried CB's advice and copied a clean set of lightmaps for the same size map but it makes no difference. Any ideas what may be wrong?

Ok, having tried everything I could think of with the lightmaps, and knowing that I had some problems with the combat zone before the problem arose I decided to try some other things. Well some playing around with the gameplayobjects has meant that the map doesnt crash at 61 or 62% but it crashes at 64% (reverting quickly to 62%) so i'm guessing that this is not a lightmaps problem and therefore this post is now in the worng forum - sorry. Still, if anyone has any ideas I would love to hear them.

Edited by MrMajorSurgerySir
Link to comment
Share on other sites

Don't take the 61% literally , it might differ a little. The big question is the error message when you load your map in windowed display mode.

You should get the missing lightmapatlas error. If your map simply crashes without yielding an error message, chances are that you have checked the 'isNightMap' property in the map tweak, but don't have SF (xpack) installed. Uncheck the property or delete the appropriate line from your init.con.

Link to comment
Share on other sites

Ok, thanks guys I will run it in windowed mode and get back to you with the error message. Couple of things though, i'm fairly sure the move from 62% to 64% was definate - in trying to fix it i attempted to run the map numerous times and the crash always happened at exactly the same point (didn't know about running in windowed mode to get an error message) either 62% before the change to gameplayobjects or 64% after - no variation what so ever. Also it's not the nightmap problem because its not checked and i have SF installed.

As ever thanks for the help - you guys are such an amazing help to us.

OK, running on a different pc (although not with the latest patch) the map crashed at 66% so now i feel stupid! The error was "Texture not found: levels/[mylevel]/colormaps/tx_s0".

In that folder of my map I have tx_s1 tx_s2 and tx_s3. I also have tx00x00 tx00x01 tx01x00 tx01x01. I don't have my archived backup maps on this PC to see what the folder included when the map worked.

Edited by MrMajorSurgerySir
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...