Jump to content
Official BF Editor Forums

Making Terrain Slopes (Image Heavy)


Recommended Posts

I follow this tutorial to build roads and create nice slopes for my terrain to the "T", but when I click apply splines my terrain disappears and all you can see is the road, the splines and the water underneath.

Is this just a major bug with the editor or am I possibly missing a step?

I get the same problem...

Link to comment
Share on other sites

  • 9 months later...

On my machine i sometimes have he same effect, but its not really a dissappearing terrain but an error in the fog setting interpretation by the editor. Try either to disable fog while working on the roads (Render menu -> Toggle Draw Fog ) or reset the fog settings in the light settings tweaker. For me it works to place the cursor into any fog setting value and then leaving the field with the TAB key to reset the fog manager. Also often happens after creating the groundhemi. Card here is an Nvidia 8600 GT.

Link to comment
Share on other sites

  • 2 weeks later...

On my machine i sometimes have he same effect, but its not really a dissappearing terrain but an error in the fog setting interpretation by the editor. Try either to disable fog while working on the roads (Render menu -> Toggle Draw Fog ) or reset the fog settings in the light settings tweaker. For me it works to place the cursor into any fog setting value and then leaving the field with the TAB key to reset the fog manager. Also often happens after creating the groundhemi. Card here is an Nvidia 8600 GT.

I have ATI 3650 HD, I had 5200 FX GeForce. Both of them didn't work with road tool. I've tryed disabling everything I can. I have Athlon 3200+ 1,5 gb DDR ram. I think it should be enough. I tryed installing editor on PC in school,(integrated 7050 geforce, if i'm right) It worked perfectly! Even it took some time for it to calculate. But what I've noticed was. It wrote in console:

[Geom] : TBM: Setting up ApplySpline to use texture size 4096 # not sure if that value is correct, it was beginning with 4XXX

[Geom] : TBM: ApplySpline uses texture size 4096

While my pc wrote "using 8192"

After I pressed Save terrain it wrote: Ignored Warning[RendDX9] : TBM: Failed 2 get old Stencil Surface Not found

I'm completly lost. :blink:

Edited by blackdeth
Link to comment
Share on other sites

No were not dead, just some smell like it.

Yea the "apply spline = no terrain" bug is known, but there is no reall solution, i've been getting it quite regular recently, it appears to happen when usein it on a slope, or when it has to alter alot of terrain on apply spline pressing. So all i can sugest is to either try... smaller roads, less height diffremnce ( less steep slopes) or just try to shape the terrain as best you can to fit the road then apply spline, or just smooth the terrain to fit the roads best you can and dont apply spline, and only build final roads.

Edited by Bensta
Link to comment
Share on other sites

  • 12 years later...

We're still reading these forums and putting the info to good use.

I hope someone will see this:  I am trying to use the method described here to draw splines and make the terrain deform to the slope of the splines.  I have used BF2editor quite a bit and feel like I am not a Noob and not an idiot.   But I can't get the terrain to conform to the road splines as described. 

I followed the steps exactly:  Create splines, connect, apply.    I am experiencing the thing others describe (the terrain disappears when applying).  I tried saving, closing the editor and then coming back in and I noticed that the terrain is changed, but not as expected.  Instead of bringing the terrain UP to the spline, a big chunk of the terrain is REMOVED instead.

Any help is appreciated....

 

Edited by Daniel S
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...