Jump to content
Official BF Editor Forums

Editor Crashes Everytime I Load A Mod (any Mod)


Dr Rank
 Share

Recommended Posts

Hey lads

I've had a good look through the forums and I have seen some similar threads, but none of the advice given appears to have any effect with this issue. Just to clarify, the editor crashes every time I load a mod, ones that previously worked. As far as I know, I haven't changed anything since it was working nicely yesterday. Here are some links to screenshots that show the messages:

http://s60.photobucket.com/albums/h29/Dr_R...editorerror.jpg

http://s60.photobucket.com/albums/h29/Dr_R...itorerrorp2.jpg

The game itself works fine, as does the mod I'm building the map for (Project Reality). I've tried re-installing both the 1.41 patch and the Project Reality mod. As someone in the forum suggested, I tried deleting all the old editor files left from the uninstall before re-installing. The only thing I haven't tried is removing BF2 completely and reinstalling (I've only got a SF cd with me so if thats what I have to do I'll have to wait a few days before I can carry on mapping :( )

Any help would be much appreciated!

Dr Rank

EDIT: I got it to work once since posting. It was completely random, I didn't change anything before or after running it :blink: But its now decided to return to its broken state.

Here is a copy of the editor log file that includes the errors:

http://s60.photobucket.com/albums/h29/Dr_R...=debugfile1.jpg

http://s60.photobucket.com/albums/h29/Dr_R...=debugfile2.jpg

EDIT: Another quick note, (Not sure if this has any bearing on the problem, but just in case...) I unistalled SF and it stopped my map crashing in game. NO IDEA WHY?!!! :huh:

Edited by Dr Rank
Link to comment
Share on other sites

It looks to me as if the editor has trouble identifying your graphics card and detects a 650 Mhz CPU ? Did you try the latest drivers for the GC ?

If you're really running a 650 Mhz Intel be aware that this is the very low end , barely able to run the game (not to mention the editor). Your 2 gb RAM looks ok.

It also seems as if the window setup of the editor has the console output supressed, try to delete the *.ini's from /bf2editor/settings (or back them up) and restart. Also you have to make sure that the initial plugin (which is the Object Editor by default) is included in the startup plugins. (done by the content.ini)

Link to comment
Share on other sites

It looks to me as if the editor has trouble identifying your graphics card and detects a 650 Mhz CPU ? Did you try the latest drivers for the GC ?

If you're really running a 650 Mhz Intel be aware that this is the very low end , barely able to run the game (not to mention the editor). Your 2 gb RAM looks ok.

It also seems as if the window setup of the editor has the console output supressed, try to delete the *.ini's from /bf2editor/settings (or back them up) and restart. Also you have to make sure that the initial plugin (which is the Object Editor by default) is included in the startup plugins. (done by the content.ini)

Hello mate! THANKYOU!!! YOU'RE A GENIOUS! ^_^ Deleted all the ini's and loaded up the editor. Tried to load a mod and it said it needed to add stuff in the Add In manager. Went there, selected all the boxes and hey presto! All I had to do then was reload all the static objects in mod manager! No idea why is was detecting such a naff cpu speed, perhaps the editor has some issues determining dual core processors.

Really appreciate the help mate :D

Dr Rank

Link to comment
Share on other sites

ah, slight problem. I have to go through the same process every time I restart my pc. :blink: I had it working on this pc for weeks without a glitch. Is there anything else I could try?

Here's some system info:

http://i60.photobucket.com/albums/h29/Dr_R...pg?t=1170464030

p.s. what should the full line of code for starting with the object editor look like?

Edited by Dr Rank
Link to comment
Share on other sites

you could try moving the PR mod folder onto your desktop and then open the editor and create a new mod (name it the same as the PR mod) choose BF2 as the parent mod... then let it load up and then check all the boxes in the mod/ mod manager... weapons/soldiers etc...

and let it load... then close the editor...

Then open the PR mod folder on your desktop and copy and paste all the files into your new PR mod folder in the

C:\Program Files\EA GAMES\Battlefield 2\mods\PR .... folder and see if that works...

keep the backup on your desktop for safe keeping... CB

Link to comment
Share on other sites

Went there, selected all the boxes and hey presto!

Don't overdo it , lol !

For testing purposes , maybe only load the Object Editor (mandatory) , perhaps the Level- and the Terrain Editor and Animation.

I think you can happily leave out the 'backup' plugin (gee, what is it used for ? perhaps someone can explain it someday ?) and (if you're not in the Maya modelling business) you can safely leave out the 'import' module.

Also the SinglePlayer Editor should only be loaded if you're working on SP/COOP support (this module interferes with creating envmaps, btw) .

Link to comment
Share on other sites

Don't overdo it , lol !

For testing purposes , maybe only load the Object Editor (mandatory) , perhaps the Level- and the Terrain Editor and Animation.

I think you can happily leave out the 'backup' plugin (gee, what is it used for ? perhaps someone can explain it someday ?) and (if you're not in the Maya modelling business) you can safely leave out the 'import' module.

Also the SinglePlayer Editor should only be loaded if you're working on SP/COOP support (this module interferes with creating envmaps, btw) .

Thanks for all your help lads, sorry I haven't replyed yet, been bogged down with work etc. which has been very frustrating cos I want to finish my map! :P I retrieved my orginal BF2 cd today, uninstalled everything, deleted all the regedit entries and reinstalled it all. Since then it seems to be behaving itself! Thankyou once again! :D

Dr Rank

Link to comment
Share on other sites

  • 1 month later...

Sorry, dont mean to be hijacking a thread, but I'm having a similar problem:

[FIXED]

http://i159.photobucket.com/albums/t121/SD...e/rc/crash1.jpg

Ignored Warning[Game] : Child item ParachuteLauncher not found!

I've been loading the mod and my map most of the evening, but now I get this all of a sudden.

This has happened once before, but I don't know whats causing it. I reinstalled the editor, reinstalled the mod.

My BF2 install hasn't changed one bit since 1.41 apart from I extracted the object zips to the Objects folder, thats it.

[/FIXED]

One other issue.

For some reason, the editor is not saving Gameplayobjects in: Gamemodes/gpm_cq/64 /32 /16

Since I have these layers, it was saving in these folders before, it was showing this in the output window as I clicked save under 'Level Editor'

Obviusly without saving in these files it is saving it in Editor/Gameplayobjects and even though there are layers there is only one file, and all the GPOs for every layer are all mixed up in the one file.

FIXED ALL

Edited by [RC]TheOne
Link to comment
Share on other sites

One other issue.

For some reason, the editor is not saving Gameplayobjects in: Gamemodes/gpm_cq/64 /32 /16

Since I have these layers, it was saving in these folders before, it was showing this in the output window as I clicked save under 'Level Editor'

Obviusly without saving in these files it is saving it in Editor/Gameplayobjects and even though there are layers there is only one file, and all the GPOs for every layer are all mixed up in the one file.

You need a LayerInit.con in... \Program Files\EA GAMES\Battlefield 2\bf2editor\mods\your_mod

look at the one in or just copy the one from... \Program Files\EA GAMES\Battlefield 2\bf2editor\mods\BF2

and sorry dont know your first problem.

Edited by Bensta-IDF
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...