Jump to content
Official BF Editor Forums
IllicitFilms

Windows Vista/7 And Bf2 Editor

Recommended Posts

"Lost devive. Cannot reload device. blah blah"

Please post a slightly more detailed error message the next time :P This error points to another program taking control over the graphics card. Make sure you have no other program requiring a DirectX device ( Graphics card or sound device ) running in parallel with the editor. Check the log file in /bf2editor/logs/ for more details

Edited by mschoeldgen[Xww2]

Share this post


Link to post
Share on other sites

Open up all your programs needed to run in admin first then run the editor. Cause if the bink: cancell or allow message pops up then it doesn't work. If you open max before bfeditor and export it directly to your exported folder in the bf2 directory you can load resource (blue + sign) and choose your object.

Share this post


Link to post
Share on other sites
Open up all your programs needed to run in admin first then run the editor. Cause if the bink: cancell or allow message pops up then it doesn't work. If you open max before bfeditor and export it directly to your exported folder in the bf2 directory you can load resource (blue + sign) and choose your object.

oh ok sweet..ill give it a go..thanks alot

Share this post


Link to post
Share on other sites

I copied MiG29 and renamed folder, but BF2Editor doesn't want to load it, it crushes. I am running it on win vista home edition basic or somming... can anyone help? I have changed tweak file so instead of mecdumbbomb I get us m82dumbbomb (i think its called m82 XD), but the editor crushes when I try to load the aircraft to preview...

I have also copied unmodified mi17, same problem, and no crush report coming out for some reason.. any help?

Edited by U-2009

Share this post


Link to post
Share on other sites

The solution is really really simple! ;)

You just need to:

- Go to the shortcut of the editor

- Right click and select properties

- Go to compatibility

- Select 'run this program as"

- Select "Windows XP (service pack 2)

You're done! :rolleyes:

I have Vista to and also had this problem. This is the best (and maybe) only way to solve this

;)

Share this post


Link to post
Share on other sites
Well ever since I reinstalled the bf2editor after installing vista, I've had issues with it not showing me my drag selection box while in the level editor(click and drag, a box appears over the area you choose to select by dragging it larger/smaller).... I just don't see the box, or at least it shows up on random for a split second 'after' I release the mouse button so it does me no good.

I can sometimes select the objects by making a guess drag over them, but it doesn't work everytime, I have to try at least 2-3 times before I can get it to select what I want.

Also sorta the same issue with editing the terrain/textures/undergrowth. my brush's won't work on the first click, I have to sometimes click twice on the same square in the mapping grid in order for it to work; this applies to everything in the terrain editor menu.

Also, if I try to select spawn points I can't get them at all, I have to either select them manualy from the resource menu, or I have to try the drag box method but that almost never works when selecting spawn points or vehicles, it mainly occasionaly works with regular statics.

All of these issues are not stopping me from doing my work, but they are making me very AGRAVATED! :( Its just taking me alot longer to get things right, and it seems less smooth... so everything just takes 4X longer

Any thoughts? :blink:

yep, i made a little video about that particular problem:

http://vimeo.com/3411597

Share this post


Link to post
Share on other sites
yep, i made a little video about that particular problem:

http://vimeo.com/3411597

I'm getting the same problem using Windows 7 Pro 32-bit. The problem with your fix though is that I don't have PS and loading a Paintshop Pro file doesn't seem to trigger the same effect - any ideas? Is it a specific file being loaded that opening a PS file triggers or something?

Share this post


Link to post
Share on other sites

reinstalling the bf2editor after installing vista, I've had issues with it not showing me my drag selection box while in the level editor(click and drag, a box appears over the area you choose to select by dragging it larger/smaller).... I just don't see the box, or at least it shows up on random for a split second 'after' I release the mouse button so it does me no good.

I can sometimes select the objects by making a guess drag over them, but it doesn't work everytime, I have to try at least 2-3 times before I can get it to select what I want.

yours,

chloe

_______________

Simulation pret

Share this post


Link to post
Share on other sites

Hey guys, it's not Vista related, but i've got the exact same problem as chloemarqz on Win 7.

There's an issue in Vista with 'Mouse trails' . Try to toggle the setting for it in your mouse control panel.

Turned the mouse trail on and off, but it doesn't make a difference, any ideas?

Pretty impossible to work on a map that way.. :-(

Share this post


Link to post
Share on other sites

If its the problem i think it is, I've managed to overcome it by opening a document in Photoshop (just close it afterwards, just needs to load one).. it's a weird solution to a weird problem, and I have absolutely no idea why and how it made it work, but give it a try.

Share this post


Link to post
Share on other sites

Here's another of those 'weirdies' :

Sometimes it helps to open WMP ( Windoze Media Player ), minimize it and then open your other graphics app, like the BF2 Editor. Helps with vertical sync, sound problems or freezing apps.

Edited by mschoeldgen[Xww2]

Share this post


Link to post
Share on other sites

Another "weirdie" then. If you find your sounds aren't playing, before you go fiddling with the BIOS, try opening Audacity (and then close it again). Usually this can fix it if your sound just suddenly drops off.

Share this post


Link to post
Share on other sites

I wanted to start editing some stuff for Battlefield 2, so I downloaded the BF2 Editor 1.3 :) Now my problem is, that I just can't seem to install it. I'm on Windows 7 x64 and put the installer on Windows XP SP2 & 3, but still the installer runs, then u see the first meter running full, then the installer totally disappear and it's nowhere to be found. Can any of you people help me with a solution? I like windows 7 quite much, also since I have 6 Gigs of Memory, so I need to run x64 OS, otherwise I would run XP, since I have more programs that has issues with x64.

Thanks in advance!

Share this post


Link to post
Share on other sites

I wanted to start editing some stuff for Battlefield 2, so I downloaded the BF2 Editor 1.3 :) Now my problem is, that I just can't seem to install it. I'm on Windows 7 x64 and put the installer on Windows XP SP2 & 3, but still the installer runs, then u see the first meter running full, then the installer totally disappear and it's nowhere to be found. Can any of you people help me with a solution? I like windows 7 quite much, also since I have 6 Gigs of Memory, so I need to run x64 OS, otherwise I would run XP, since I have more programs that has issues with x64.

Thanks in advance!

Just asking... do you have bf2 the game installed with the latest patch?

Share this post


Link to post
Share on other sites

Sorry if this was already asked, but since I'm on Win 7, I can't drag objects in real time anymore. I select an object in level editor, then drag it, but it won't show it moving until I let go and it snaps to the new position. Any ideas?

edit: nevermind, it fixed itself somehow... :S

Edited by Outlawz

Share this post


Link to post
Share on other sites

Sorry if this was already asked, but since I'm on Win 7, I can't drag objects in real time anymore. I select an object in level editor, then drag it, but it won't show it moving until I let go and it snaps to the new position. Any ideas?

edit: nevermind, it fixed itself somehow... :S

Hmm i got the same, you might know what could have fixed it? Its pretty annoying i am on win7 64bit now aswell but already had the draging problem on vista....

Share this post


Link to post
Share on other sites

Hmm i got the same, you might know what could have fixed it? Its pretty annoying i am on win7 64bit now aswell but already had the draging problem on vista....

No idea, I got it again.

Share this post


Link to post
Share on other sites

Bump

Running Photoshop, then bfeditor (and closing PS after loading the mod&level, just to be sure) fixes the issue on my side, been doing it for a while, hasn't failed once.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...